No pxe boot on virtual box guests

Robert Markula robert at
Tue Jan 26 16:53:18 CET 2016

The other way works as well: Having FAI on a dedicated server (in our
case as a KVM host) and the FAI client in VirtualBox. Using FAI 4.2.5
here. Never tried having both server and Client in VirtualBox though.



Am 26.01.2016 um 16:36 schrieb Frank Thommen:
> Hi Chris,
>> Thomas went through all steps with me for a couple of days.. and we
>> both come the conclusion
>> that Virtual Box must be the culprit.
>> I’ve a faiserver as guest and want to pxe boot another guest; the
>> client gets an IP address but not the pxelinux.0
>> Connecting locally on the faiserver with a tftp client the download
>> works, hence the tftp server works.
>> Does anyone know about this problem with/among VBox guests among each
>> other?
>> I checked all kinds of network VBox offers: Nat, Nat network,
>> Internal Network, Bridged.. no way.
>> Thanks so much!
>> Best,
>> Chris
> I'd confirm your findings:  I tried a similar setup a while ago (FAI 4
> server and FAI client as VB guests on an OpenSuSE 13 host) with a
> myriad if different VB network settings and none worked. I finally
> gave up after a few days.  However it worked fine, when having the FAI
> server as VB guest and the FAI client being a real ("metal") PC in our
> network. I  consluded, that the internal VB PXE/TFTP/Bootp server was
> "somehow" interfering with FAI's.
> My conclusion: Save your energy and don't try this kind of setup :-)
> frank

More information about the linux-fai mailing list