No pxe boot on virtual box guests

John G Heim jheim at
Tue Jan 26 16:56:10 CET 2016

I'm not sure what a screen shows while a machine PXE boots. (Sorry, I'm 
blind.) So this may be a dumb suggestion but you can tell what files a 
machine is asking the tftp server for during a PXE boot by turning on 
verbose mode on the tftp server. With tftpd-hpa, you add -vvvv to the 
end of the TFTPD_OPTIONS line at the end of the file 
/etc/defaults/tftpd_hpa. Then you can do "tail -f /var/log/syslog" on 
the tftp server  and watch the client ask for each file in turn durng a 
pxe boot. It's quite entertaining, actually. :-)

On 01/26/2016 09:36 AM, Frank Thommen wrote:
> Hi Chris,
>> Thomas went through all steps with me for a couple of days.. and we 
>> both come the conclusion
>> that Virtual Box must be the culprit.
>> I’ve a faiserver as guest and want to pxe boot another guest; the 
>> client gets an IP address but not the pxelinux.0
>> Connecting locally on the faiserver with a tftp client the download 
>> works, hence the tftp server works.
>> Does anyone know about this problem with/among VBox guests among each 
>> other?
>> I checked all kinds of network VBox offers: Nat, Nat network, 
>> Internal Network, Bridged.. no way.
>> Thanks so much!
>> Best,
>> Chris
> I'd confirm your findings:  I tried a similar setup a while ago (FAI 4 
> server and FAI client as VB guests on an OpenSuSE 13 host) with a 
> myriad if different VB network settings and none worked. I finally 
> gave up after a few days.  However it worked fine, when having the FAI 
> server as VB guest and the FAI client being a real ("metal") PC in our 
> network. I  consluded, that the internal VB PXE/TFTP/Bootp server was 
> "somehow" interfering with FAI's.
> My conclusion: Save your energy and don't try this kind of setup :-)
> frank

More information about the linux-fai mailing list