/dev/md1 is already in use. SW raid

Michael Tautschnig mt at debian.org
Tue May 3 16:29:22 CEST 2011

Hi David,

Sorry for confusing those files...

> Here it is, this worked.
> Commands.pm
>     294   # check RAID arrays if there are pre-existing ones
>     295   &FAI::push_command("mdadm --stop --scan && mdadm --assemble --scan --config=$FAI::DATADIR/mdadm-from-examine.conf",
>     296     "", "mdadm_startall_examined") if (scalar(keys %FAI::current_raid_config));
>     297   foreach my $id (keys %FAI::current_raid_config) {
>     298     my $md = "/dev/md$id";
> Thank you for your help on this.

"this worked" == your server got installed nicely? That'd be cool, I'll then see
which changes are to be made for the most proper solution. As you noticed, there
might also be a need for changes in Exec.pm (well, thanks a lot for that, I
might have missed this).

Best regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.uni-koeln.de/pipermail/linux-fai/attachments/20110503/c12c227d/attachment.bin>

More information about the linux-fai mailing list