question on a java install script

Michael Tautschnig mt at
Thu Dec 23 19:06:36 CET 2010

Hi David,

> Hi,
> I've written a small script that I have put into faiconfig/scripts/MYCLASS as 10-setup-java.  The script runs fine, with no errors. All indications in the logs are that it worked fine and that java and tomcat should be present, yet when I boot the client after FAI install there is no java or tomcat.  The license file is /etc/java as expected, but none of the packages have actually been installed.  Thinking that somehow I was installing on the nfsroot if possible, I tried adding $ROOTCMD before the apt-get with no success. That created errors complaining that that debconf couldn't find the license file. Can anyone see what I'm doing wrong?


I think things are much easier if you put this into a debconf/* file in your
config space, e.g., debconf/DEFAULT:

sun-java6-bin   shared/accepted-sun-dlj-v1-1    boolean true
sun-java6-jdk   shared/accepted-sun-dlj-v1-1    boolean true
sun-java6-jre   shared/accepted-sun-dlj-v1-1    boolean true

This way you can simply install your sun-* packages and tomcat6 via one of your
package_config/* files.

Hope this helps,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <>

More information about the linux-fai mailing list