question on a java install script

David Dreezer dave at
Thu Dec 23 18:49:57 CET 2010


I've written a small script that I have put into faiconfig/scripts/MYCLASS as 10-setup-java.  The script runs fine, with no errors. All indications in the logs are that it worked fine and that java and tomcat should be present, yet when I boot the client after FAI install there is no java or tomcat.  The license file is /etc/java as expected, but none of the packages have actually been installed.  Thinking that somehow I was installing on the nfsroot if possible, I tried adding $ROOTCMD before the apt-get with no success. That created errors complaining that that debconf couldn't find the license file. Can anyone see what I'm doing wrong?


# copyright Thomas Lange 2001-2007, lange at

error=0 ; trap "error=$((error|1))" ERR

fcopy -iM /etc/java/sun-java6.license

debconf-loadtemplate shared /target/etc/java/sun-java6.license;  /bin/echo 'set shared/accepted-sun-dlj-v1-1 true'|debconf-communicate;
apt-get -y install sun-java6-jdk sun-java6-bin sun-java6-jre tomcat6

exit $error

David Dreezer
Customer Advocate, Social Strata, Inc.

Online Community HQ Since 1996 · LiveCloud · Eve Community

Follow us: @socialstrata

More information about the linux-fai mailing list