setup-storage fails when preserving LVM volume

Nicolas Courtel courtel at
Fri Dec 17 17:03:00 CET 2010

Hello Michael,
>> Executing: mdadm --examine --scan --verbose -c partitions
>> Previous partitions overflow begin of preserved partition /dev/sda2
>> I tried several values for the /local volume, but always get the
>> same message. Here's the debug format.log, which happens to be
>> pretty short.
> [...]
> There seems to be some problem with the size or position of your /boot
> partition. It might be caused by a change in alignment, which may even have
> introduced a bug!? Could you please change the size of /boot to 511, report back
> and, if it works, also do yet another run and send the debug logs of both runs?

The /boot partition has be built by FAI 3.3.5 (setup-storage 1.2.1), 
asking for a size of 512 like I still do now. The parted command was the 

parted -s /dev/sda mkpart primary ext3 32256B 534643199B

The installation does not work better after setting the size of /boot to 
511, the log is exactly the same as with 512. Setting the size to 480 
makes it work, though, the log is joined.

I have also tried to preserve the existing /boot partition, and this has 
worked fine:

disk_config disk1 preserve_lazy:1 always_format:1
primary        /boot           0    ext3    rw


-------------- n?chster Teil --------------
Ein Dateianhang mit Bin?rdaten wurde abgetrennt...
Dateiname   : format.log.bz2
Dateityp    : application/x-bzip
Dateigr??e  : 6054 bytes
Beschreibung: nicht verf?gbar
URL         : <>

More information about the linux-fai mailing list