System stalls (for 15-30 minutes) during savelog

Carsten Aulbert carsten at
Thu May 7 16:36:38 CEST 2009


after the jaunty kernel gives the same result as the originally tried
2.6.26, so I think I can mostly exclude that it's a kernel issue.

So, one of our new boxes (Asus board with 2 GPUs on it) boots via PXE,
starts the FAI install (3.2.16) and runs through it fine, however, when
almost done it tries to run savelog and during that it fails, loses its
network interface and stalls for 15-30 minutes.

It always fails when trying to transfer the content of dmesg, thus on
the FAI server this file is always of size 0 while other files before
are transferred fine. This was tested with both rsh and ssh.

Also, when I log into the system via ssh and call dmesg interactively,
it also kills the network interface and the install then of course
stalls as well. Writing dmesg directly into a file and copying it over
via scp works, but does not reveal anything strange.

shows a (bad) screen shot of the last lines during the installation. In
this state it takes between 15-30 minutes until some time-out kicks in
and the machine is rebooted.

When switching over to tty4 I do see this weird stuff on the screen:

Anyone with an idea what's happening to this nice and shiny box?



More information about the linux-fai mailing list