fai 2.8.4 / cfengine scripts segfaults

Steffen Grunewald steffen.grunewald at aei.mpg.de
Mon Jun 20 08:35:17 CEST 2005

On Sun, Jun 19, 2005 at 11:31:16PM +0200, Michael Tautschnig wrote:
> [...]
> > 
> > > Are you by chance using the version from the version from the testing
> > > distribution (1.6.5-2)? As I got the errors too, but only on some of my hosts, I
> > > tried the version from stable (1.6.5-1), and this solved the problem for me!
> > 
> > What first confused me was that packages.debian.org still lists 1.6.5-1
> > for stable, and 1.6.5-2 for testing - which isn't true (I installed a pure
> > sarge system, and got 1.6.5-2 during the fai run. Had to manually downgrade
> > to 1.6.5-1 since fai installs would fail with 1.6.5-2 --- so the problem
> > isn't limited to softupgrades :-((( )
> I'm sorry, but I think something has gone wrong at your site -- I'm running
> Debian/Sarge systems and they do not have 1.6.5-2, but instead stayed at
> 1.6.5-1. Please double-check your sources.list or the contents of your logfiles,
> where 1.6.5-2 got installed!

Hmmm. I'm using an intermediate debmirror for those tasks. 
On my desktop machine (which is still wasting bandwidth by querying 
ftp.fu-berlin.de), 1.6.5-1 would be shown by apt-cache showpkg cfengine, 
but the machines using the miror would report

This is somewhat strange. The mirror synchronizes with ftp2.de.debian.org,
and (of course) keeps not only sarge but testing and unstable as well.

Looking into the mirror's repository I find

phobos:/data/debian/mirror-i386/debian/dists/sarge/main/binary-i386# grep cfengine Packages
Package: cfengine
Suggests: cfengine-doc
Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb

This is puzzling... looking deeper into it:

phobos:/data/debian/mirror-i386/debian# grep /cfengine_1 */*/*/*/Packages
dists/etch/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb
dists/sarge/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb
dists/sid/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb
dists/stable/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-1_i386.deb
dists/testing/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb
dists/unstable/main/binary-i386/Packages:Filename: pool/main/c/cfengine/cfengine_1.6.5-2_i386.deb

Huh? Why does stable show -1, while sarge lists -2?

Have to investigate. 
Looks like I invited a lot of trouble - I guess this wouldn't be the only 
problem :-(((


Steffen Grunewald * MPI fuer Gravitationsphysik (Albert-Einstein-Institut)
SciencePark Golm, Am Mühlenberg 1, D-14476 Potsdam * http://www.aei.mpg.de
* e-mail: steffen.grunewald(*)aei.mpg.de * +49-331-567-{fon:7233,fax:7298}
No Word/PPT mails - http://www.gnu.org/philosophy/no-word-attachments.html

More information about the linux-fai mailing list