AW: AW: Error message after installing via fai-cd before reboot with UBUNTU

Fabian Hartmann fabian.hartmann at
Wed Dec 3 08:53:51 CET 2014

Hmm, I tried it out as you described, but unfortunately without any success.
I'm still getting the same error message, even though the script seems to be run according to the log messages.
Script is 755-chmoded.

Then I wanted to have a look at another shell, but there are only two other consoles with messages from dmesg, no shell where I could actually do something on the live-system.
How can I configure the live-system to provide me with shell-access in another terminal. I remember to have had this while using fai with Debian.


Fabian Hartmann                AG
Dipl. Inf. Ing. FH                      Hardturmstrasse 127, 8005 Zürich
fabian.hartmann at        Tel: +41 55 214 18 43 

> -----Ursprüngliche Nachricht-----
> Von: linux-fai [mailto:linux-fai-bounces at] Im Auftrag von
> Thomas Lange
> Gesendet: Dienstag, 2. Dezember 2014 10:11
> An: fully automatic installation for Linux
> Betreff: Re: AW: Error message after installing via fai-cd before reboot with
> >>>>> On Tue, 2 Dec 2014 07:59:47 +0000, Fabian Hartmann
> <fabian.hartmann at> said:
>     > And I remember to not have this problem in the beginning while working
> with an example disk_config from FAIBASE with a /tmp partition...
>     > So that could probably be causing the problem! Is it necessary to create a
> partition for /tmp or is there a work-around by hooking in another faiend-
> script?
> You can write a hook that is called after task mountdisks, mount a tmpfs on
> top of /target/tmp. That should do the trick.
> /srv/fai/config/hooks/mountdisks.DEFAULT:
> #! /bin/bash
> mkdir -p $target/tmp
> mount -t tmpfs tmpfs $target/tmp
> --
> regards Thomas

More information about the linux-fai mailing list