Black screen hinders the client build on the target host

George VerDuin gfv2008-home at
Wed Dec 4 07:27:09 CET 2013


I am about to repeat history.  I began a thread on 3/15/2013 reporting 
and fixing a bunch of issues, one issue being loss of video upon the 
client building a new target host.  Since I lost the fix detail in 
March, I'm back in December to carefully document the fix this time around.

Here is what I've done:  A few days ago I purged all vestiges of fai 
from my workstation named tango and installed a fresh 4.0.8 version from 
fai project wheezy repository.  Tango host OS is Ubuntu 12.04LTS with 
all updates.  I followed FAI Guide section 4.3 using SaltStack to load 
and configure fai server thus I have good record of configuration.  My 
last step was to
     ...# fai-chboot -IFv -u nfs:// demohost
and then initiate a build on the same Target hardware as used in March.

While watching the console on the target host, all progresses fine for 
1:12 min  after power-up when the display goes black.  Prior to failure, 
PXE has successfully loaded vmlinuz and turned control over to the new 
kernel.  The failure follows the Init 2.88 message. Perhaps 5sec later 
the monitor power led turns from green to yellow proving the interface 
has shut down.  For a few more minutes the eth0 and hard drive remain 
busy and finally go idle themselves.

In March, Toomas Tamm  believed the video interface hardware in my 
particular host is a strange variety, and it seems correct to me. The 
bad news is that his suggestion does not work today, and modprobe has 
such a large list I doubt I will be able to sort it out.  The black 
screen in March was solved by something unknown to me at this moment.  
If no driver is the problem, I am most puzzled about why the interface 
is shut down upon failure to find suitable driving software.  Why does 
linux not return to whatever worked OK a few seconds earlier even though 
it is not the ideal solution?

The build on the target by fai client did not finish, but much happened 
correctly.  I have copies of error.log and dmsg.log to go over in the 
next couple days searching for things to fix.  Actually I have been more 
successful than in March and with less pain getting to this stage 
following my purge and restart.  The best news is that the black screen 
is today's nuisance failure, because a ssh session works fine.

Can anyone add anything to the loss of console failure?


More information about the linux-fai mailing list