Stuck on 'switching to colour frame buffer device'

Toomas Tamm tt-fai at
Tue May 24 08:20:17 CEST 2011


Framebuffer devices tend to cause all sorts of trouble during FAI
installations. I try to prevent the problems by some or all of the

1) banning "discover" from trying to detect them via using a suitable
file in /etc/modprobe.d . Debian "squeeze" comes with such a file by
default, it is called /etc/modprobe.d/fbdev-blacklist.conf and contains
lines like :

blacklist arkfb
blacklist aty128fb

2) looking at device-specific drivers and ways to disable them. For
example, some nvidia card-specific driver modes need to be disabled with
a kernel parameter nouveau.modeset=0 . There is also a modprobe.d
alternative, but I have not tried it.

3) I also disable the coloured FAI banner and limited scrolling area by
keeping a file named ..../nfsroot/live/filesystem.dir/.nocolorlogo
around. This is an old but relatively unknown FAI feature.

If all these do not help, you can temporarily insert printouts, followed
by "sleep" statements into /usr/sbin/fai, /usr/lib/fai/subroutines/*,
class/*, and even initramfs, eg

echo "have reached hardware detection"
sleep 5

So you you will be able to pinpoint the statement right before the
screen gets messed up. The latter suggestion probably does not apply to
your case, since it seems to be related to a kernel driver.

Toomas Tamm

On Mon, 2011-05-23 at 20:36 +0200, Marcus Karlsson wrote:
> Hello.
> We're trying to install Ubuntu 10.04 using FAI and are currently having some
> trouble doing that. When we try to reinstall a machine it boots over NFS but
> halfways into the boot it stops, the screen goes blank and the only message on
> it is the line below.
> [ 17.399034] Console: switching to colour frame buffer device 210x65
> We get the same result when we use our old hardy-config which has been updated
> to lucid as well as when we use the standard fai configuration from the lucid
> packages. 
> Our NFS server is running FAI 3.4.4 on Solaris 10/sparc but the nfsroot was
> created on a Ubuntu 10.04 host which was upgraded from 8.04. We also tried
> doing that on a Debian 6.0 machine, both of them with the same result.
> Any ideas of what could be wrong?
> 	Marcus

More information about the linux-fai mailing list