Strange AUFS problem with squeeze...

Dirk Geschke dirk at
Fri Mar 11 13:38:49 CET 2011

Hi Michael,

> > For example:
> > 
> > fcopy: copied /var/lib/fai/config/files/etc/init.d/fai-update/TRAIN to /target/etc/init.d/fai-update
> > update-rc.d: error: unable to read /etc/init.d/fai-update
> > 
> [...]
> Does it help if you add a `sleep 1` command somewhere in between, i.e., is it
> some timing/concurrency issue? Does this also happen if you manually create a
> file and try to access it immediately afterwards?

ah, I just forgot this one-email-thread. The problem is solved, it
was my mistake...

The error was in my fai-scripts where I forgot to use $ROOTCMD, so fcopy
worked withint the chroot-environment during installation whereas the
postinst-Skript worked outside the chroot. So it acted on the AUFS-
system, and fcopy on the target-system.

I corrected this and now there are no problems, at least FAI works now.

Why I AUFS dies is still not known, but I do not care about this any

Best regards and thank you for replying


| Dr. Dirk Geschke       / Plankensteinweg 61    / 85435 Erding        |
| Telefon: 08122-559448  / Mobil: 0176-96906350 / Fax: 08122-9818106   |
| dirk at / dirk at  / kontakt at |

More information about the linux-fai mailing list