question on a java install script

David Dreezer dave at
Thu Dec 23 19:59:13 CET 2010

Thank you both.  So, essentially you are both saying that this part is not necessary?

debconf-loadtemplate shared /target/etc/java/sun-java6.license;

That I don't need to be doing anything with the license file? 

David Dreezer
Customer Advocate, Social Strata, Inc.

Online Community HQ Since 1996 · LiveCloud · Eve Community

Follow us: @socialstrata

On Dec 23, 2010, at 10:16 AM, Toomas Tamm wrote:

> On Thu, Dec 23, 2010 at 09:49:57AM -0800, David Dreezer wrote:
>> Hi,
>> I've written a small script that I have put into faiconfig/scripts/MYCLASS as 10-setup-java.  The script runs fine, with no errors. All indications in the logs are that it worked fine and that java and tomcat should be present, yet when I boot the client after FAI install there is no java or tomcat.  The license file is /etc/java as expected, but none of the packages have actually been installed.  Thinking that somehow I was installing on the nfsroot if possible, I tried adding $ROOTCMD before the apt-get with no success. That created errors complaining that that debconf couldn't find the license file. Can anyone see what I'm doing wrong?
> Hello!
> I did not find error in your script, but I faced installing java just
> some days ago, with success.
> My solution was to put the following into debconf/JAVA :
> ------------------------ snip -------------------------
> # Tell sun jre that we have already accepted the license.
> sun-java6-jre shared/accepted-sun-dlj-v1-1 boolean true
> ------------------------ snip -------------------------
> and then list the java packages in a normal packages/JAVA file.
> I must admit that I did not actually test this in an install, but in a
> softupdate, where this worked as expected. I should also note that I
> am installing lenny.
> Toomas Tamm

More information about the linux-fai mailing list