Tuan A. Tran tuantran167 at gmail.com
Tue Jun 28 18:16:01 CEST 2005

Thanks Thomas and Dominik,

I got a weird error as you can see below.  I checked and libnet-perl
was installed as well as other packages. However, fai complains about
unmet dependencies. I have not figure out the connection between
nfsroot and portmapper as Dominik's conjecture.


Building Dependency Tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 1339kB disk space will be freed.
(Reading database ... 7039 files and directories currently installed.)
Removing tasksel ...
Reading Package Lists... Done
Building Dependency Tree... Done
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Adding additional packages to /usr/lib/fai/nfsroot:
module-init-tools dhcp3-client ssh file rdate hwinfo portmap
bootpc rsync wget rsh-client less dump reiserfsprogs usbutils
hdparm smartmontools parted mdadm lvm2
dnsutils ntpdate dosfstools cvs jove xfsprogs xfsdump
sysutils dialog discover mdetect libnet-perl netcat libapt-pkg-perl
grub lilo kudzu dmidecode
Reading Package Lists... Done
Building Dependency Tree... Done
wget is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libnet-perl: Depends: perl (>= 5.6.0-16) but it is not going to be installed
E: Broken packages
Removing `diversion of /sbin/discover-modprobe to
/sbin/discover-modprobe.distrib by fai'

On 6/28/05, Dominik Kasprzyk <dk at star.sr.bham.ac.uk> wrote:
> Cheers, it's good to know I'm wrong.
> I remember seeing that kind of error in the portmapper when I tried to run the NIS master server setup in a postinstall script before the NIS services started up.  I can only conjecture that the portmapper wasn't informed about the NIS services.  The rpcinfo -p implies that in your case the nfs mounter is fully working, so maybe nfsroot is looking inside itself for its own portmapper?
>                         Dominik.
> On Mon, 27 Jun 2005 14:21:47 +0200
> Thomas Lange <lange at informatik.Uni-Koeln.DE> wrote:
> > >>>>> On Mon, 27 Jun 2005 12:52:14 +0100, Dominik Kasprzyk <dk at star.sr.bham.ac.uk> said:
> >
> >     > The error looks familiar and reminds me of the nfs mount failing (the rest I think is usual output).  In my case this was because I tried to mount from the same machine to the same machine and I discovered you can't do that.  Leaving the DEBIANMIRROR entry blank will allow the setup to continue if you're not using nfs for the mirror and if you are attempting to use it, can I suggest vsftpd server and a mount --bind command to bind the mirror to the ftp server directory to test the working of the rest of the setup.
> >
> >
> > You can mount faiserver:/files/whatever /newlocation on the same
> > machine by using NFS. I'm doing this since many years. I think there's
> > a portmapper or nfsserver problem.
> >
> > --
> > regards Thomas
> >

More information about the linux-fai mailing list