Dominik Kasprzyk dk at star.sr.bham.ac.uk
Tue Jun 28 12:55:45 CEST 2005

Cheers, it's good to know I'm wrong.

I remember seeing that kind of error in the portmapper when I tried to run the NIS master server setup in a postinstall script before the NIS services started up.  I can only conjecture that the portmapper wasn't informed about the NIS services.  The rpcinfo -p implies that in your case the nfs mounter is fully working, so maybe nfsroot is looking inside itself for its own portmapper?


On Mon, 27 Jun 2005 14:21:47 +0200
Thomas Lange <lange at informatik.Uni-Koeln.DE> wrote:

> >>>>> On Mon, 27 Jun 2005 12:52:14 +0100, Dominik Kasprzyk <dk at star.sr.bham.ac.uk> said:
>     > The error looks familiar and reminds me of the nfs mount failing (the rest I think is usual output).  In my case this was because I tried to mount from the same machine to the same machine and I discovered you can't do that.  Leaving the DEBIANMIRROR entry blank will allow the setup to continue if you're not using nfs for the mirror and if you are attempting to use it, can I suggest vsftpd server and a mount --bind command to bind the mirror to the ftp server directory to test the working of the rest of the setup.
> You can mount faiserver:/files/whatever /newlocation on the same
> machine by using NFS. I'm doing this since many years. I think there's
> a portmapper or nfsserver problem. 
> -- 
> regards Thomas

More information about the linux-fai mailing list