fai 2.8.4 / cfengine scripts segfaults

Steffen Grunewald steffen.grunewald at aei.mpg.de
Sun Jun 19 20:58:52 CEST 2005

On Sat, Jun 11, 2005 at 01:07:45PM +0200, Michael Tautschnig wrote:
> > Hi,
> > 
> > during my latest softupdate I got an error processing my cfengine scripts. The
> > log states:
> > 
> > /usr/bin/fai-do-scripts: line 173: 23726 Segmentation fault      ./$file --no-lock -v -f $file -D${cfclasses} >>$LOGDIR/cfengine.log 2>&1
> > 
> > Removing the --no-lock option from fai-do-scripts let the softupdate run
> > without any errors.
> > 
> > Is this a bug, or am I doing something wrong?
> > 
> > fai: 2.8.4
> > cfengine: 1.6.5

I ran into this yesterday when I had to install an emergency replacement
for a failed server. Thanks to FAI this would only take 20 minutes, but this
time I got lots of errors during the config part.

> Are you by chance using the version from the version from the testing
> distribution (1.6.5-2)? As I got the errors too, but only on some of my hosts, I
> tried the version from stable (1.6.5-1), and this solved the problem for me!

What first confused me was that packages.debian.org still lists 1.6.5-1
for stable, and 1.6.5-2 for testing - which isn't true (I installed a pure
sarge system, and got 1.6.5-2 during the fai run. Had to manually downgrade
to 1.6.5-1 since fai installs would fail with 1.6.5-2 --- so the problem
isn't limited to softupgrades :-((( )

Note that 1.6.5-[12] have been submitted two years apart...


> If it solves the problem for you too, we should file a bug report against
> cfengine.

That's probably the way to go. I will look in the BTS whether there's
something to add...


More information about the linux-fai mailing list