fai and sarge

Erik Rossen rossen at freesurf.ch
Mon Oct 20 07:57:43 CEST 2003

On Sun, Oct 19, 2003 at 12:17:48PM -0400, Yaroslav Halchenko wrote:
> I'm trying to make FAI work on sarge distribution and getting into some
> problems. IS there anybody who succeded with installing sarge distro
> from sarge FAI 'server'? Are there any specifics?

Can you tell us your problems?  A while ago I succeeded in setting up a
sid box (called "tennis") using FAI version 2.50 installed on a
mostly-woody FAI server (called "hulk").

The most perplexing problem that I had came after I built a "sid"
nfsroot and tried to install a client.  FAI's cfengine scripts refused
to be called because the file package in sid no longer recognised
cfengine scripts.  I worked around the problem by installing the file
package from woody.  I have not yet sent a bug report to the file

Here are my notes from the experience (please forgive the long lines):

2003-10-02 Set up an nfsroot for FAI for doing unstable installs in hulk:/scratch/fai/nfsroot-sid
- Needed to create new /etc/fai/fai-sid.conf with FAI_SOURCELIST=`cat /etc/fai/sources-sid.list` in it.
- Needed to install the sid version of debootstrap.
- Resolved a dependency problem and got rid of exim4 by changing fai-sid.conf to:
FAI_DEBOOTSTRAP_OPTS="--arch i386 --exclude=pcmcia-cs,ppp,pppconfig,pppoe,pppoeconf,dhcp-client,exim4,exim4-base,exim4-config,exim4-daemon-light --include=libt
- make-fai-nfsroot -v -f /etc/fai/fai-sid.conf would not work until I did: unset LC_CTYPE; unset TMPDIR
- Needed to copy /root/.ssh/known_hosts from the old nfsrootmanually to the new nfsroot to permit automatic uploading of logs.
- Edited /scratch/fai/nfsroot-sid/etc/apt/preferences by hand to change the pin settings which had been copied directly from hulk.
- Removed tcsh-i18n from /scratch/fai/config/package_config/DEFAULT because it does not exist in sid.  Hopefully that will not cause problems for stable...
- Something is setting the link /usr/sbin/sendmail to point at /usr/sbin/exim, even though ssmtp is installed.
- Some of the DEFAULT scripts failed because file-4.04 failed to recognise them as cfengine scripts, calling them "ASCII English text".  Removed libmagic1 from nfsroot-sid and installed old version of file manually.
- Installing PHP4 provokes an interactive response.  Need to divert...
- FAI badly constructs /etc/hosts assuming the the "domain" returned by DHCP contains only one value, i.e.   tennis.demo.prolibre.com lan.prolibre.com prolibre.com tennis
- there remains a problem with console-common not being properly configured (or was it just the locales package that had not been properly installed?)
- FAI leaves apt in a somewhat dangerous "yes" state.  For example "apt-get -u upgrade" will not ask [Y/n].  This comes from the /etc/apt/preferences that is copied directly from the FAI nfsroot.

Erik Rossen                          ^    OpenPGP key: 2935D0B9
rossen at freesurf.ch                  /e\   "Use GnuPG, see the
http://people.linux-gull.ch/rossen  ---    black helicopters."

More information about the linux-fai mailing list