[Debian] Schwachstellen in phpMyAdmin vor Version 2.11.9.6 bzw. 3.2.2.1 - DSA-1918-1

WiN Site Security Contacts win-sec-ssc at lists.dfn-cert.de
Mo Okt 26 14:45:15 CET 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Liebe Kolleginnen und Kollegen,

soeben erreichte uns nachfolgende Warnung des Debian-Teams. Wir geben
diese Informationen unveraendert an Sie weiter.

CVE-2009-3697 / RedHat Bug ID 528769 - SQL Injektion in phpMyAdmin
moeglich

  In phpMyAdmin werden Benutzereingaben fuer verschiedene Parameter der
  PDF-Schema Generatorschnittstelle unzureichend gefiltert. Entfernte
  Angreifer koennen diese Schwachstelle dazu ausnutzen, um beliebige
  SQL-Befehle in der Datenbank auszufuehren.

CVE-2009-3696 / RedHat Bug ID 528769 - Cross-Site Scripting
Schwachstelle in phpMyAdmin

  In phpMyAdmin werden Benutzereingaben fuer MySQL Tabellennamen
  unzureichend gefiltert. Entfernte Angreifer koennen diese
  Schwachstelle dazu ausnutzen, um mit einem manipulierten Tabellennamen
  beliebige Skript oder HTML-Befehle im Browser fremder Benutzer
  auszufuehren.

Betroffen sind die folgenden Software Pakete und Plattformen:

  Paket phpmyadmin in der old stable Distribution (etch) vor Version
  2.9.1.1-13 
  Paket phpmyadmin in der stable Distribution (lenny) vor Version
  2.11.8.1-5+lenny3 
  Paket phpmyadmin in der unstable Distribution (sid) vor Version 3.2.2.1-1 

  Old Stable Distribution (etch)
  Stable Distribution (lenny)
  Unstable Distribution (sid)

Vom Hersteller werden ueberarbeitete Pakete zur Verfuegung gestellt.

Hersteller Advisory:
  http://www.debian.org/security/2009/dsa-1918


(c) der deutschen Zusammenfassung bei DFN-CERT Services GmbH; die
Verbreitung, auch auszugsweise, ist nur unter Hinweis auf den Urheber,
DFN-CERT Services GmbH, und nur zu nicht kommerziellen Zwecken
gestattet.

Mit freundlichen Gruessen,
		Klaus Moeller, DFN-CERT

- -- 
Dipl. Inform. Klaus Moeller (Incident Response Team)
Phone: +49 40 808077-555, Fax: +49 40 808077-556

DFN-CERT Services GmbH, https://www.dfn-cert.de,  Phone  +49 40 808077-555
Sitz / Register: Hamburg, AG Hamburg, HRB 88805,  Ust-IdNr.:  DE 232129737
Sachsenstrase 5, 20097 Hamburg/Germany, CEO: Dr. Klaus-Peter Kossakowski

- -----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - ------------------------------------------------------------------------
Debian Security Advisory DSA-1918-1                  security at debian.org
http://www.debian.org/security/                          Thijs Kinkhorst
October 25, 2009                      http://www.debian.org/security/faq
- - ------------------------------------------------------------------------

Package        : phpmyadmin
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE Id(s)      : CVE-2009-3696 CVE-2009-3697
Debian Bug     : 552194

Several remote vulnerabilities have been discovered in phpMyAdmin, a tool
to administer MySQL over the web. The Common Vulnerabilities and Exposures
project identifies the following problems:

CVE-2009-3696

  Cross-site scripting (XSS) vulnerability allows remote attackers to
  inject arbitrary web script or HTML via a crafted MySQL table name.

CVE-2009-3697

  SQL injection vulnerability in the PDF schema generator functionality 
  allows remote attackers to execute arbitrary SQL commands. This issue
  does not apply to the version in Debian 4.0 Etch.

Additionally, extra fortification has been added for the web based setup.php
script. Although the shipped web server configuration should ensure that
this script is protected, in practice this turned out not always to be the
case. The config.inc.php file is not writable anymore by the webserver user
anymore. See README.Debian for details on how to enable the setup.php
script if and when you need it.


For the old stable distribution (etch), these problems have been fixed in
version 2.9.1.1-13.

For the stable distribution (lenny), these problems have been fixed in
version 2.11.8.1-5+lenny3.

For the unstable distribution (sid), these problems have been fixed in
version 3.2.2.1-1.

We recommend that you upgrade your phpmyadmin package.

Upgrade instructions
- - --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 4.0 alias etch
- - -------------------------------

Source archives:

  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-13.dsc
    Size/MD5 checksum:     1021 0a8c412c5481b2260562ab5649c70d8b
  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1.orig.tar.gz
    Size/MD5 checksum:  3500563 f598509b308bf96aee836eb2338f523c
  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-13.diff.gz
    Size/MD5 checksum:    57060 68fc6b7269343482b96326553dd1e0c0

Architecture independent packages:

  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-13_all.deb
    Size/MD5 checksum:  3605314 85eaa36525db64fdd0ba9955c9def399

Debian GNU/Linux 5.0 alias lenny
- - --------------------------------

Source archives:

  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1.orig.tar.gz
    Size/MD5 checksum:  2870014 075301d16404c2d7d58216efc14f7a50
  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny3.diff.gz
    Size/MD5 checksum:    63773 a3c38a698e954534517a81570e9fc9fa
  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny3.dsc
    Size/MD5 checksum:     1547 db7c29dbd8ad5758ea8283ebbde9c611

Architecture independent packages:

  http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny3_all.deb
    Size/MD5 checksum:  2883628 da6a70575f8ae6608910a1c5aaf81f1c


  These files will probably be moved into the stable distribution on
  its next update.

- - ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce at lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
- -----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iQEcBAEBAgAGBQJK5DziAAoJECIIoQCMVaAcUQAH/0julm1B+LL0DHVhN0HFkTB4
ufBJ/bUuHS/aVPQEFE8iPCPAof/zgHcjfkHXyxJ0Nq1RnQ4pENePSgRFlNxjJPop
yKFwklh7clFozO1nukuldP0Ql28LzqRv9JGwCc9bGOm6YxrunnO/B5f8/4jQvgRN
Wvye92shb7tpykTaYnez8aw4cJMIbDCiAir4l9ev610LDo+uz33PvkhstB2f0EYg
Mtf5A5QWZpkHEKLFg0xmSOYp3FfMS+kFz6t8OTuCiBWqZpNlPwMJbbdJGwcA2jDo
b1WFq5xvRH8pVWfYKMIJeL52dpyzmPFYHiD8cR2lTdeSC5ckpdYgerRb+2OA/rY=
=Laew
- -----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFK5afrk0kIxZMiiQ8RAlTvAKCSvNqjiTouetC7eEQawZDZDRq0zwCgqB1P
U/cqM1/uieUSpFANcWkWS1o=
=ncwx
-----END PGP SIGNATURE-----