Debian Etch-update: perl compiliert nicht mehr

Uwe Döbereiner udoebus at kud.com
Fr Jul 18 11:40:47 CEST 2008


Hallo,

meine Debian Etch Installation habe ich durcheinander gebracht, als ich
python2.9 dinstallieren wollte, weil ich mich in der Bedienung von Plone
in's Abseits begab. 

Dabei wollte dann das Install die Hälfte meiner Anwendungen wegwerfen. 
Nun habe ich das System weitgehend erhalten, aber mein update läuft
nicht mehr. 

Fehlermeldung beginnt mit
debconf: Perl may be unconfigured (Can't locate File/Spec/Unix.pm in
@INC (@INC

"Compilation failed in require at /usr/lib/perl/5.8/IO/File.pm line 12."

Mir ist nich klar, warum perl aufgerufen wird und auch nicht, wie der
ursprüngliche Aufruf erfolgt. Welches Direktory muss ich mit welchem
Aufruf zur Korrektur als Ziel angeben, damit perl sich wieder zurecht
findet?

Gruss

Uwe





-------------- nächster Teil --------------
debconf: Perl may be unconfigured (Can't locate File/Spec/Unix.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/l ib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/s ite_perl .) at /usr/share/perl/5.8/File/Spec.pm line 21.
Compilation failed in require at /usr/lib/perl/5.8/IO/File.pm line 12.
BEGIN failed--compilation aborted at /usr/lib/perl/5.8/IO/File.pm line 12.
Compilation failed in require at /usr/share/perl/5.8/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
(Reading database ... dpkg: error processing /var/cache/apt/archives/libktnef1_4 %3a3.5.5.dfsg.1-6_i386.deb (--unpack):
 files list file for package `libusb-0.1-4' is missing final newline
Errors were encountered while processing:
 /var/cache/apt/archives/libktnef1_4%3a3.5.5.dfsg.1-6_i386.deb
Processing was halted because there were too many errors.
Can't locate File/Spec/Unix.pm in @INC (@INC contains: /etc/perl /usr/local/lib/ perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/ perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/perl/5.8/ File/Spec.pm line 21.
Compilation failed in require at /usr/share/perl/5.8/File/Find.pm line 423.
Compilation failed in require at /usr/bin/debsums line 10.
BEGIN failed--compilation aborted at /usr/bin/debsums line 10.
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/bin/debsums ]; then  /usr/bin/debsums --generate=nocheck -sp /var/cache/apt/archives; fi'
E: Sub-process returned an error code
E: Sub-process /usr/bin/dpkg returned an error code (1)
Some errors occurred while unpacking. I'm going to configure the
packages that were installed. This may result in duplicate errors
or errors caused by missing dependencies. This is OK, only the errors
above this message are important. Please fix them and run [I]nstall again
Press enter to continue.


Mehr Informationen über die Mailingliste Linux-Users