Paket Abhängigkeit bei Debain kann nicht aufgelöst werden

Thorsten Kramm kramm at sozialmedia.de
Do Mär 15 14:43:38 CET 2007


Hallo Leute,

ich wollte gerade auf einem Debian Etch ein apt-get upgrade druchführen.

Dann gibt es folgenden Fehler:
$apt-get install tzdata
	Reading package lists... Done
	Building dependency tree... Done
	You might want to run ‘apt-get -f install’ to correct these:
	The following packages have unmet dependencies.
  	 libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20) but 			 
2.3.6.ds1-13 is to be installed
	E: Unmet dependencies. Try ‘apt-get -f install’ with no packages 	(or 
specify a solution).

Woher das "ubuntu" kommt ist mir schleierhaft.
Das gesamte Update schlägt fehl, weil tzdata nicht installiert werden kann.

Wenn ich tzdata mit dpkg installieren, geht's auch nicht. Klar!
$dpkg -i /var/cache/apt/archives/tzdata_2007b-1_all.deb
(Reading database ... 13924 files and directories currently installed.)
Unpacking tzdata (from .../tzdata_2007b-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/tzdata_2007b-1_all.deb 
(--install):
  trying to overwrite `/usr/share/zoneinfo/Canada/Atlantic', which is 
also in package locales
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
  /var/cache/apt/archives/tzdata_2007b-1_all.deb

Hat jemand einen Tip, wie ich aus diesem Dilemma rauskomme.

Danke für Eure Hinweise.

Thorsten Kramm



Mehr Informationen über die Mailingliste Linux-Users