devfs und scsi-Brenner

Ulrich Wiederhold wubuwei at gmx.net
Do Nov 27 13:47:12 CET 2003


Hi,
* Marcel Kossin <mkossin at enumerator.org> [031127 08:16]:
> > Festplatten laufen unter /dev/scsi/host0/bus0/target0/lun0/partX, der
> > brenner ist device 4 und sollte somit unter
> > /dev/scsi/host0/bus0/target4/lun0/generic ansprechbar sein, ist er aber
> > nicht. /dev/sg1 tut es auch nicht.
> 
> In diesem Fall sollte es /dev/scsi/host0/bus0/target4/lun0/cd sein. Das 
> Device /dev/sg1 hast Du meines erachtens nach nur, wenn auch der devfsd 
> läuft (und das vorher genannte Device verfügbar ist :-).

in lun0 existiert nur "generic", kein cd.
> > Bekomme folgende Ausgabe:
> > root at home:/home/fzzgrr# mount /brenner/
> > mount: /dev/scsi/host0/bus0/target4/lun0/generic is not a block device
> 
> Ist eine CD-Rom (kein Rohling) eingelegt?
Ein gebrannter Rohling, der auch definitiv unter 2.4.X funktioniert hat.

> Hast Du Dir einen eigenen Kernel gebaut und SCSI-CD-Rom Support vergessen?
Habe den Kernel selbst gebaut. isofs und sr_mod sind geladen, trotzdem
dieselbe Fehlermeldung.

> Hast Du einen IDE-Brenner und die SCSI-Emulation nicht richtig 
> eingerichtet?
SCSI Brenner und SCSI-Patte. Patte funktioniert wunderbar.
 
> Vielleicht kannst Du uns ein paar mehr Informationen zu Deiner 
> Konfiguration geben?
Adaptec 2940UW Kontroller, Teac 6x Brenner

(grep SCSI .config):

# CONFIG_BLK_DEV_IDESCSI is not set
# SCSI device support
CONFIG_SCSI=y
CONFIG_SCSI_PROC_FS=y
# SCSI support type (disk, tape, CD-ROM)
# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
# CONFIG_SCSI_MULTI_LUN is not set
CONFIG_SCSI_REPORT_LUNS=y
CONFIG_SCSI_CONSTANTS=y
CONFIG_SCSI_LOGGING=y
# SCSI low-level drivers
# CONFIG_SCSI_ACARD is not set
# CONFIG_SCSI_AACRAID is not set
CONFIG_SCSI_AIC7XXX=y
# CONFIG_SCSI_AIC7XXX_OLD is not set
# CONFIG_SCSI_AIC79XX is not set
# CONFIG_SCSI_ADVANSYS is not set
# CONFIG_SCSI_MEGARAID is not set
# CONFIG_SCSI_SATA is not set
# CONFIG_SCSI_BUSLOGIC is not set
# CONFIG_SCSI_CPQFCTS is not set
# CONFIG_SCSI_DMX3191D is not set
# CONFIG_SCSI_EATA is not set
# CONFIG_SCSI_EATA_PIO is not set
# CONFIG_SCSI_FUTURE_DOMAIN is not set
# CONFIG_SCSI_GDTH is not set
# CONFIG_SCSI_IPS is not set
# CONFIG_SCSI_INIA100 is not set
# CONFIG_SCSI_PPA is not set
# CONFIG_SCSI_IMM is not set
# CONFIG_SCSI_SYM53C8XX_2 is not set
# CONFIG_SCSI_QLOGIC_ISP is not set
# CONFIG_SCSI_QLOGIC_FC is not set
# CONFIG_SCSI_QLOGIC_1280 is not set
# CONFIG_SCSI_DC395x is not set
# CONFIG_SCSI_NSP32 is not set
# CONFIG_SCSI_DEBUG is not set

Gruß
Uli

-- 
'The box said, 'Requires Windows 95 or better', so I installed Linux - TKK 5




Mehr Informationen über die Mailingliste Linux-Users