dpkg-Problem / Radeon 9200

Hartmut Wahl hwahl at hwahl.de
So Nov 9 19:02:52 CET 2003


Hallo Til,

On Sat, Nov 08, 2003 at 10:09:20PM +0100, Til Schubbe wrote:
> Unpacking fglrx-glc22 (from fglrx-glc22_4.2.0-4.2_i386.deb) ...
> dpkg: error processing fglrx-glc22_4.2.0-4.2_i386.deb (--install):
>  trying to overwrite /usr/X11R6/lib/libGL.so.1.2', which is also in
> package xlibmesa3-gl
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  fglrx-glc22_4.2.0-4.2_i386.deb
> 
> Was bedeutet diese Fehlermeldung und wie kriege ich das .deb
> installiert?
> 

Die Fehlermeldung bedeutet, das in dem Paket z.B eine Datei drin ist,
die auch in xlibmesa3-gl ist. Bei RH oder Suse, oder wofür auch immer
das rpm gedacht war ist xlibmesa offensichtlich im Paket für den
Grafikserver dabei. Du kannst versuchen xlibmesa3-gl zu deinstallieren: 
"apt-get remove xlibmesa3-gl". Evtl. will apt-get dann aber auch
Programme deinstallieren, die Du unbedingt haben willst, dann wird es
fummeliger, ein ganz übler Hack wäre es z.B. in
/var/lib/dpkg/info/xlibmesa3-gl.list einfach die Datei(en die vermutlich
auch noch zu Konflikten führen) zu entfernen. 

Man soll auch fake-packages basteln können, also eins das so tut als
wäre es xlibmesa3-gl, damit die abhängigen Pakete zufrieden sind. Das
habe ich aber noch nicht gemacht.  Vielleicht hat da wer anderes einen
guten Tip. Alternativ, guck mal was in dem Paket drin ist (geht gut mit
"mc"). und Kopiere Dir den Treiber, Xserver, etc. raus den Du brauchst.

Gruß
  Hartmut

-- 
Hartmut Wahl <hwahl (at) hwahl (dot) de>
www: http://www.hwahl.de
PGP: http://www.hwahl.de/HartmutWahl.asc



Mehr Informationen über die Mailingliste Linux-Users