Remote touchless install with a static IP?

Thomas Lange lange at
Fri Oct 2 12:26:51 CEST 2020

>>>>> On Thu, 1 Oct 2020 23:20:13 +0000, "Holland, Jake via linux-fai" <linux-fai at> said:

    > I tried that iso as the CD on a local vm as a sort of "getting started"
    > step, but it seemed to go into an infinite loop of installing.
    > I tried

You need to set the boot order of your VM to first local disk, then
CD. Otherwise you have this infinite loop.

    > After a few tries, this menuentry gets me to where in my vm it looks like
    > it's trying to do something with the .iso I've put into the hard drive:
    > menuentry "jake fai"  --class gnu-linux --id jake-fai4 {
    >     loopback loop (hd1,gpt2)/faime-PR5UDQU6.iso
    >     search --set=root --file /FAI-CD
You must boot the VM from CD. Do not put the ISO onto the hard drive
and try to boot from it. This will not work.

    > As a guess after looking through options, I tried adding this:
I'm pretty sure it cannot work this way.

Let's see why your VM installation does not work.

Did you try to boot this ISO?

Does it boot and does the installation start and finishes? If not,
please put the fai.log onto so I can look at the

And maybe join the IRC channel #fai, then we can better debug further things.

regards Thomas

More information about the linux-fai mailing list