Upgrade error in nfsroot

Andreas Heinlein aheinlein at gmx.com
Wed Feb 26 09:20:47 CET 2020


I have to correct myself: upgrading the nfsroot worked, but the NFS root is not functional now. When booting, it says "cannot execute /etc/init.d/rcS". Indeed, /etc/init.d/rcS does not exist.

Is rcS supposed to be a real file or a link somewhere?



Am 26.02.20 um 08:31 schrieb Andreas Heinlein:
> Hello,
> when upgrading FAI inside the nfsroot with 'fai-make-nfsroot -v -k -N', I got:
> Preparing to unpack .../15-fai-nfsroot_5.9.2_all.deb ...
> dpkg-divert: error: 'diversion of /etc/init.d/rcS to /etc/init.d/rcS.orig by fai-nfsroot' clashes with 'diversion of /etc/init.d/rcS to /etc/init.d/rcS.distrib by fai-nfsroot'
> dpkg: error processing archive /tmp/apt-dpkg-install-hXzBfK/15-fai-nfsroot_5.9.2_all.deb (--unpack):
>  new fai-nfsroot package pre-installation script subprocess returned error exit status 2
> when upgrading FAI from 5.9.1 to 5.9.2
> I had to manually chroot to the nfsroot and remove the diversion, then it worked. Maybe this should be included in the preinst script.
> Bye,
> Andreas

More information about the linux-fai mailing list