iso cd not bootable

Robert Markula robert at
Wed Mar 29 21:39:09 CEST 2017

Am 29.03.2017 um 18:12 schrieb Николич Роберт:
> One time boot selection menu lets me choose between hard drive and
> flash drive, but no matter what i choose it still boots from hard drive.
> When i remove hard drive and turn on computer i get "No bootable
> device -- insert boot disk" message. And im still able to get to boot
> selection menu, and see my flash drive (as the only option), but when
> i pick it i still get same "No bootable device" message.
> I now tried to boot from this flash drive on 3rd computer and
> succesfully got to FAI installation menu.
> So it works on 2 computers.

Just to make sure, did you run a filesystem integrity check on the flash
drive after dd'ing the image to it?

You may try another flash drive. Maybe your particular type of flash
drive doesn't get along with your particular flavour of BIOS. On rare
occasions I've experienced BIOSes that would refuse booting from certain
flash drives, but would boot happily from all other flash drives.

You may also try to create a live CD using the same image as on the
flash drive and try booting from the live CD on the computer in question
in order to rule out any errors with the FAI image itself. If booting
from CD works, then the flash drive is definately the culprit.


More information about the linux-fai mailing list