fai problems with partitioning

Benedict Wright admin at ist.tugraz.at
Tue Jul 16 08:47:27 CEST 2013


I have tried to set up  FAI 4.0.6 for Debian 7.
I followed the tutorial at 
http://wiki.fai-project.org/wiki/Installation_walkthrough but i get the 
same error no matter what disk_config i use (tried the one in the 
tutorial and the on bellow and a few others).

my current disk_config looks as follows:

disk_config disk1 disklabel:msdos bootable:1 fstabkey:uuid

primary /      250      ext4  rw,noatime,errors=remount-ro
logical swap   200-1000 swap  sw
logical /var   600-1300 ext4  rw,noatime         createopts="-L var -m 
5" tuneopts="-c 0 -i 0"
logical /tmp   100-1G   ext4  rw,noatime,nosuid,nodev createopts="-L tmp 
-m 0" tuneopts="-c 0 -i 0"
logical /usr   1G-8G    ext4  rw,noatime,nodev   createopts="-L usr"
logical /home  100-50%  ext4  rw,noatime,nosuid,nodev createopts="-L 
home -m 1" tuneopts="-c 0 -i 0"

The error message:
Starting setup-storage 1.4
Using config File: /var/lib/fai/config//disk_config/DEFAULT

Table header not yet seen while reading warning: /dev/sda contains GPT 
signatures, indicating that it has a GPT table. However, it does not 
have a valid fake msdos partition table, as it should. Perhaps it was 
corrupted -- possibly by a program that doesn't understand GPT partition 
tables. ... Please report this error to Debian Bug Tracking....
Fatal error: Installation stopped.

Has anybody got any ideas on how i could solve this?


Benedict Wright BSc
Institut für Softwaretechnologie
TU Graz
Inffeldgasse 16B/II
8010 Graz
tel.: 0316 873 5714
fax.: 0316 873 5706

More information about the linux-fai mailing list