trying to use $classes instead of --class per fai(8)

andrew bezella abezella at
Thu Dec 15 03:03:33 CET 2011

hello -

i'm using fai 3.4.8 for a dirinstall in the following manner: 
/usr/sbin/fai --class CLASS1,CLASS2 --verbose \
  --cspace nfs://fai/srv/fai/config --hostname $instance dirinstall $TARGET

which works wonderfully and does just what i want (thanks fai devs!).
however, the fai manpage mentions the alternative of $classes, which i
am interested in but have not been able to get working: 
-c|--class class[,class]
        Define classes.  Multiple classes must be comma separated.
        If not specified, use the shell environment variable $classes
        (space separated).  The first class has lowest priority.

based on this i tried changing the incantation to: 
export classes="CLASS1 CLASS2"
fai --class --verbose --cspace nfs://fai/srv/fai/config [...]

but that resulted in fai.log reporting: 
List of all classes:  --verbose

thinking i may have misunderstood how much should be left unspecified, i
then tried leaving "--class" out entirely.  that failed with: 
Please use -c or -N. Aborted

looking at the code a bit i wasn't able to see how this might be
expected to work.  it's also entirely possible i'm not getting how it is
supposed to be used or that it's not appropriate for this usage.
obviously there are alternatives and what i have works; still, it's been
nagging at me so i thought i'd check.

thanks in advance for any help or information!


andrew bezella <abezella at>
Internet Archive

More information about the linux-fai mailing list