not booting from disk

Toomas Tamm tt-fai at
Thu Apr 7 17:46:53 CEST 2011

On Thu, 2011-04-07 at 15:03 +0100, Michael Tautschnig wrote:
> Hi,
> [...]
> > also tried to put it in /dev/ccisss/c0d0 but that fails with "Your embedding area is unusually smal./ core.img won't fit on it... 
> > 
> [...]
> I think the device name should be ok, but apparently your partition layout is
> not. I haven't looked at your script, but probably you are starting the first
> partition right at first few bytes instead of leaving sufficient space for an
> MBR+GRUB to fit in, or even an extra partition if you use a GPT disk label.

Grub2 (aka grub_pc) is very (in my opinion too) picky in where it agrees
to be installed into. If my memory serves correctly, the old grub
(grub-legacy) could be installed, for example, into an extended
partition, and control passed to it from a Windows bootloader which in
turn was booted from the Windows MBR. This let me leave the MBR, with
special features to access Windows recovery partitions, intact.

With grub-pc, I never found a combination which worked this way. I have
now developed a workaround for dual-boot systems, but I generally regard
grub2 as too restrictive for implementing "creative" boot strategies.
Maybe there are good reasons for it to work like this, I do not know...

Thus my suggestion is to try to use the old grub instead.



More information about the linux-fai mailing list