FAI-CD aborts after "mounting root filesystem"

Holger Parplies wfai at parplies.de
Mon Aug 17 15:53:56 CEST 2009


Sebastian Schmidt wrote on 2009-08-17 09:34:36 +0200 [Re: FAI-CD aborts after "mounting root filesystem"]:
> Hello,
> I could progress a bit with my problem. I simply tried a lot
> of things: root=/dev/ram0, root=/dev/cdrom, root=/dev/scd1 and finally
> root=/dev/nfs works in the kernel line in the menu.lst. I also removed
> the whole ip=... part in the kernel line.
> Looks like /dev/nfs is the place to find the nfsroot on the cd.
> But I'm now getting a kernel-panic:
> Begin: Mounting root file system... ...
> Begin: Running /scripts/nfs-top ...
> Done.
> [     15.884497] RPC: Registered udp transport module.
> [     15.885198] RPC: Registered tcp transport module.
> [     15.950168] NET: Registered protocol family 17
> ipconfig: eth0: SIOCGIFINDEX: No such device
> ipconfig: no devices to configure
> /init: .: 1: Can't open /tmp/net-eth0.conf
> [     16.006805] Kernel panic - not syncing: Attempted to kill init!

I'm either completely misunderstanding you, or you are saying "root=/dev/nfs
works, except that it doesn't work". I don't think this is progress, it is
just failing in a different way at the same point. Let's look at the root=
parameters you mention above.

	/dev/ram0  - first ramdisk
	/dev/cdrom - convenience link created by udev, I believe, once it's
                     running (which it isn't yet)
	/dev/scd1  - *second* SCSI CDROM device
	/dev/nfs   - root mounted over NFS

All of that is probably not what you want.

Is your CDROM device IDE or SCSI (as far as the kernel is concerned; SATA
devices are usually mapped to SCSI, as are IDE devices in new kernels, I
believe)? Have you tried /dev/hdc (presuming it's the IDE secondary master) or

Looking at the beginning of this thread, this may not be your problem (I have
no experience with FAI on Ubuntu), but your choice of boot devices seems to
offer reasonable explanations for not working.

> I don't know what's the cause of this problem. I have no nfs-top script
> in my fai-scripts directory created.

It's not FAI yet, it's still initramfs trying to mount the root FS. It is
failing when trying to initialize the ethernet card (which it would need to
use to access the NFS server) because it doesn't find one. You don't need an
ethernet card to access your CDROM ;-).

Hope that helps.


P.S.: You know you can edit GRUB command lines for one boot attempt without
      changing menu.lst, don't you?

More information about the linux-fai mailing list