FAI 3.2.4, live-initramfs + unionfs

Thomas Roth t.roth at gsi.de
Tue Jan 22 16:29:28 CET 2008

Hi all,

I've tried to upgrade  a FAI server from 3.1.8 to 3.2.4. Not
surprisingly, things didn't work any more. After a while, I started from
scratch, installing FAI and related packages and building a new nfsroot.
 Still, FAI does not work, and there are two points that worry me:

- The nfsroot location: I put "/srv/fai/nfsroot" into
/etc/fai/make-fai-nfsroot.conf, yet the system is placed in
I tried fai-chboot to see what my TFTP setup should look like, and the
boot append produced in pxelinux.cfg reads:
 "append initrd=initrd.img ip=dhcp  root=/dev/nfs
nfsroot=/srv/fai/nfsroot-new boot=live  FAI_FLAGS=verbose,sshd,reboot

Trying to install a client with that throws me into BusyBox, from where
I can find out that "faiserver:/srv/fai/nfsroot" is mounted under
"/live/image". Wherever else I've seen a nfsroot system in use, it was
mounted under "/" .

- Trying several combinations of "append" parameters, I once ended up
with a client having the nfsroot mounted nicely as root, that is under
"/". But there, "/tmp" was read-only, as were other crucial directories
of the system. This could mean that a read-write layer of filesystem was
missing. And indeed, browsing the FAI docu, I found on the very last
lines of the FAI-Wiki entry on XEN (not that I would be interested in
that atm) a hint that one needs unionfs installed and working.
This is bad news, as messing with unionfs always gives you a hard time
(we're using it extensively at our site).
In particular my efforts to create the unionfs kernel modules failed
with errors that hint at incompatibilities between the unionfs sources
(1.4) and the kernel I need it for (2.6.22). The unionfs-source change
log says that 1.4 is meant for kernel 2.6.18. However, 2.6.22 is the
minimum kernel version I need to get the hardware working.

So my questions are:  What is the correct directory structure for the
nfsroot, what is the correct PXE kernel append line, and do I indeed
need unionfs to get the whole thing working?

Many thanks for any help,


More information about the linux-fai mailing list