Module (version magic) and Sata pb :

Jean-Paul BALOCHE jpbaloche at
Tue Jul 25 10:17:48 CEST 2006


My configuration :
AMD 64 3000+ / 512 Mo
SATA 162 Go
Motherboard Gigabyte
Kernel : linux-image-2.6.16-fai-kernels_1_i386.deb

This is the first time I configure FAI.
The first steps are ok without any problem :
fai-setup is ok : 
	make-fai-nfsroot finished properly.
	FAI setup finished.
then I have burned a boot cd-rom with DHCP option.
When I boot the client with the CD-ROM, everything is ok :
10-base-classes  20-hwdetect.source  50-host-classes are ok.

1/ Module problem :
then in the log console, I've got error messages regarding modules :

	ipv6: version magic '2.6.16-fai-kernels SMP 386 gcc-4.1' should be
'2.6.16-fai-kernels SMP 386 gcc-4.0'

I've got the same message for : ide_core, aec62xx, alim15x3
amd74xx, cmd64x, cs5530, htp34x,htp366, pdc202xx_new, pdc202xx_old,
piix, rz1000, serverworks, siimage, sis5513, slc90e66, via82cxxx

and then I have those messages :
	scsi_mod : no version magic, tainting kernel

2/ SATA pb :
the installation continue, it says it found sda hard drive, then fai
tried to create file systems :
	mke2fs -q -c -j /dev/sda1
and then I have this message twice :

----------------------------	ata1: command 0x25 timeout, stat 0x50
host_stat 0x24
and the client is out of order. I don't understand why "ata1" !

Can you please help me, I have read many things on the mailling list but
everything I tried didn't change anything.

Thank you very much for your help,

More information about the linux-fai mailing list