problem in fai-setup

Lorenzo Campo lorenzo118 at
Tue Nov 8 16:52:20 CET 2005

I'm trying to use FAI to install a small beowulf cluster (5 nodes). I 
installed Sarge on the master and I installed all FAI packages (fai, 
fai-kernels and all suggested packages). I used mkdebmirror to create a 
local mirror of sarge, but when I try to run fai-setup -v I have following 
errors (I tried many times):

Account $LOGUSER=tom2 already exists.
Make sure that all install clients can
log into this account without a password.
/home/tom2/.ssh/known_hosts remained unchanged.
/home/tom2/.ssh/authorized_keys created.
User account tom2 set up.
Using configuration files from directory /etc/fai
Creating FAI nfsroot can take a long time and will
need more than 250MB disk space in /usr/lib/fai/nfsroot.
/usr/lib/fai/nfsroot already exists. Removing /usr/lib/fai/nfsroot
Creating nfsroot for sarge using debootstrap
Calling debootstrap sarge /usr/lib/fai/nfsroot 

I: Retrieving debootstrap.invalid_dists_sarge_Release
E: Failed getting release file 

chroot: cannot run command `apt-get': No such file or directory

I put
in fai.conf and

in make-fai-nfsroot.conf (just to try to find the file Release, but I tried 
Until now I didn't even tried to boot other nodes, because I have this 
error in the setup. What could be the cause?
To avoid using the local mirror, I tried to use directly the original 
remote mirror (that is in both fai.conf and 
make-fai-nfsroot.conf. In this case everything is ok until it tries the 
mounting on the local directory mnt2 when it tries for a while and then 
exits unsuccessfully.
Any idea?
Thank you
Lorenzo Campo  

More information about the linux-fai mailing list