Fwd: fai-setup

Tuan A. Tran tuantran167 at gmail.com
Tue Jul 5 19:06:33 CEST 2005

Hi Thomas,

I looked the output of make-fai-nfsroot and found that the
installation process complained when it tried to configure

As a test (maybe dangerous), I remove dhcp3-client in the line which
starts "packages=...". Then I installed an old version of mknbi for my
master server (amd64). After that I ran
fai-setup -v and everything seems to be OK. I got the following output

`/etc/fai/fai.conf' -> `/usr/lib/fai/nfsroot/etc/fai/fai.conf'
`/etc/fai/fai.log' -> `/usr/lib/fai/nfsroot/etc/fai/fai.log'
`/etc/fai/make-fai-nfsroot.conf' ->
`/etc/fai/make-fai-nfsroot.log' ->
`/etc/fai/menu.lst' -> `/usr/lib/fai/nfsroot/etc/fai/menu.lst'
`/etc/fai/sources.list' -> `/usr/lib/fai/nfsroot/etc/fai/sources.list'
`/usr/share/fai/etc/apt.conf' -> `/usr/lib/fai/nfsroot/etc/apt/apt.conf'
Shadow passwords are now on.
Architecture-specific modutils configuration not found, using defaults
DHCP environment prepared. If you want to use it, you have to enable
the dhcpd and the tftp-hpa daemon.
Warning: elf format and --first32pm require Etherboot 5.0 or later
BOOTP environment prepared.
Removing `diversion of /sbin/discover-modprobe to
/sbin/discover-modprobe.distrib by fai'
make-fai-nfsroot finished properly.
Adding line to /etc/exports: /usr/local/share/fai,ro)
Adding line to /etc/exports: /usr/lib/fai/nfsroot,ro,no_root_squash)
Re-exporting directories for NFS kernel daemon...done.

   You have no FAI configuration space yet. Copy the simple examples with:
   cp -a /usr/share/doc/fai/examples/simple/* /usr/local/share/fai
   Then change the configuration files to meet your local needs.

FAI setup finished.
>From what I read in FAI manual. This is done.

Now I encounted another problem. When I booted a client (using pxe
boot ROM), it complains about no tftp (TFTP: file error). I see
tftpd-hpa daemon running and dhcp3-server running. What could be my
error here?


More information about the linux-fai mailing list