make-fai-nfsroot stops

Christoph Keller christoph.keller at
Tue Oct 16 13:43:15 CEST 2001

Ok one thing is that from one hour to the next make-fai-nfsroot stopped
It took me a while to find out why the clients don´t start the
The system is running on the actual woody and fai worked without
problems the day before.
Then I tested debootstrap and it had problems to make the installation
debootstrap woody /tmp/test/ 
normaly should run without problems but it doesn´t.
Version of debootstrap is also not working
(with this error: E: Couldn't download libpcap0g)
So at the moment i´m not able to use fai with debootstrap.
I will try to make a base.gz and then never touch it again.

What I mean with "no kernel" is installed is that the make-fai... script
stops when it has problems with debootstrap and "install_kernel_nfsroot()"
and a lot of other things are not processed.


On Tue, Oct 16, 2001 at 12:34:31AM +0200, Jens Ruehmkorf wrote:
> Hi all, hi Christoph!
> > I tried to create the nfsroot with debootstrap today. (i want to use
> > woody) The problem is that it skips and finish uncompleted. no kernel
> > is installed so I can´t start the clients for installation.
> What do you mean by "no kernel" is installed? You use debootstrap for
> building a nfsroot to boot from, I suppose. If you want to install modules
> to have them available after booting you can do that by
> # cd /tmp/chroot/
> # mount -t proc proc proc/
> # chroot . /bin/bash
> $ do-whatever-you-need-to-install-your-kernel
> $ <Ctrl-D>
> # umount proc/
> There are several things that don't work with debootstrap, but I have not
> heard of any problems you report (and the debian-boot people do quite a
> lot of testing).
> Ethan Benson fixed some bugs this weekend, try debootstrap from
> as well.
> > With verbose output the last I can see is:
> >
> > -
> > Setting up console-tools (0.2.3-23.2) ...
> > Looking for keymap to install:
> > NONE
> > -
> > afterwards there come a lot of blank lines.
> Do you have gcc installed on your box? debootstrap uses "dpkg
> --print-architecture" which uses gcc.
> Do you have a stable and well maintained debian-system on which you can
> test debootstrap out? Since debootstrap is only made up of some shell-
> scripts you can simply build it on your potato box with something like:
> # echo deb-src ./ >> /etc/apt/sources.list
> # apt-get update
> # chroot 644 /var/state/apt/lists/*_Sources
> # <Ctrl-D>
> $ fakeroot apt-get -b source debootstrap
> $ su root
> # dpkg -i debootstrap_blah.deb
> > also there are a lot of dependency problems (with libc6,...) but I
> > don´t know if this is normal
> That's normal. debootstrap works pretty simple: it's a shell-script that
> unpacks a predefined list of packages (that used to make up the base.tgz).
> dpkg --force is used several times to install all packages which still
> leaves dpkg complaining about dependencies; it doesn't know that we are
> going to install everything desired.
> So what should you do?
> 1. Build/get the newest version of debootstrap
> 2. Test it out on various boxes; I assume the box you use is somewhat
>    misconfigured (I tested two woody and potato boxes, it works fine).
> 3. Have a look at the scripts to understand what debootstrap did and tell
>    in more detail how and where it failed.
> 4. Find out what was wrong and send an email to 115699 at
>    suggesting what to do.
> Kind regards,
> Jens
> --
> ruehmkorf at informatik dot uni hyphen koeln dot de


More information about the linux-fai mailing list