Kernel (2.4.X series) not doing the initial boot.

Stephane Enten tuf at
Mon Oct 8 23:16:21 CEST 2001

On Mon, Oct 08, 2001 at 07:53:45PM +0200, Geert Stappers wrote:
 > At 17:55 +0200 10/8/01, Stephane Enten wrote:
 > >
 > >I re-tested with CONFIG_FILTER enabled, without any results.
 > Thanks for the report.
 > The CONFIG_FILTER idea came for a bad encounter I had with dhcpd.
 > (
 > $ strings /usr/sbin/dhcpd-2.2.x  | grep -i filter
 > Can't install packet filter program: %m
 > policy-filter
 > $
 > )
 > CONFIG_PACKET is set in the .config you sent to the list.

Oh, okay, however I think this has to to on the server side, but is
unrelated on the client side.

I ran some tests today and the one who gave me at least *some* result
was the idea of putting arguments in the LILO prompt.

 > >Trying to find out the problem, I enabled IPCONFIG_DEBUG in the
 > >ipconfig (net/ipv4/ipconfig.c) code, hoping to see some debug
 > >message, but didn't get one. I did the same with NFSROOT_DEBUG
 > >(in fs/nfs/nfsroot.c) with the same result.
 > >
 > >I start to be in doubt if the ipconfig code is executed at all ...
 > >
 > >I'll now examine the remaining things:
 > > - Trying to force the root= and nfsroot= params (as Chad suggested)
 > > - Trying with an older kernel (2.4.4 as Jens suggested)
 > > - Trying a "known to work" 2.2 kernel as Thomas suggested
 > I'm also clueless.
 > When bright ideas don't work,
 > I fall back to simple ideas as checking UTP cables
 > and having the link LED lit on the repeater.

I'm pretty sure this isn't a connectivity problem, since the switch is
seeing port changes ...

But I agree on that, when everything is allied against you, cutting the
problem into pieces usually works.


More information about the linux-fai mailing list