Changes to make-fai-nfsroot

John Paul Adrian Glaubitz glaubitz at
Sat Feb 16 19:59:46 CET 2013


I just recently upgraded one of our FAI install servers from Squeeze to 
Wheezy which meant upgrading the FAI packages from 3.4.7 to 4.0.

After that, I ran into problems with the nfs roots created with 
make-fai-nfsroot (now called fai-make-nfsroot).

The first problem was that the directory hierarchy for the nfs roots has 
been changed making Debian Live fail to boot. Formerly, the nfs root was 
located in /srv/fai/nfsroot/nfsroot-<dist>-<arch>/live/filesystem.dir 
while the new version removed the "live/filesystem.dir" sub-directories. 
After creating the sub-directories and moving the sub-directory back 
into the old hierachy, Debian Live would boot again.

However, I still ran into more problems. While Debian Live worked now 
and the FAI installation was initiated, it stops at a very early stage 
with "fai: installation aborted" without further error messages.

Manually invoking "fai install" actually kicks off the installation, 
however it stops with FAI refusing onto a running system (which is 

Can anyone give me some further hints which parts of the FAI 
configuration I need to update to get a working fai-make-nfsroot? The 
changes have to be related to fai-make-nfsroot since the FAI version in 
the created nfs roots for Wheezy was already at 4.0.

Is the change in the directory hierarchy intentional? I'm not sure 
whether Debian Live requires the original structure.



  .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz at
`. `'   Freie Universitaet Berlin - glaubitz at
   `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

More information about the linux-fai-devel mailing list